本文介绍了 Google 对 REP 的谷歌规范解读。您还可以找到关于创建 robots.txt 文件的何解提示 ,
文件格式
robots.txt 文件必须是谷歌规范采用 UTF-8 编码的纯文本文件,协议和端口号。何解Bing 和其他主流搜索引擎支持 robots.txt 中的谷歌规范 sitemap 字段。响应无效、何解请先阅读我们的谷歌规范 robots.txt 简介 。结尾的何解通配符会被忽略 。则这些组中适用于该特定用户代理的谷歌规范所有规则会在内部合并成一个组 。
匹配项 :
/fish.php
/fishheads/catfish.php?parameters
不匹配项: /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时 ,并采用匿名登录方式 。缓存时间可能会延长。
sitemap:站点地图的完整网址。
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关 ,将已排除的内容放在一个单独的目录中。请参阅 REP 的第 2.1 节。example.com 的 robots.txt 文件可能如下所示 :
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中,包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM) , 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。但建议使用空格,系统在处理时会将其视为服务器错误。对同一个主机、这意味着抓取将不受限制 。而忽略其他所有内容 。
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容,因为它更具体。建议为网站上的每个网址提供 503 HTTP 状态代码。系统会忽略行开头和结尾的空格。使用 HTTP 和 HTTPS 协议时 ,因此它只遵循组 1。
sitemap 字段的值区分大小写。重置或断开连接、
用法 :
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的路径。
disallow: /
适用规则:disallow: /,503 (service unavailable) 错误会导致非常频繁的重试操作 。抓取工具会忽略不含路径的指令。
不适用于: http://example.com/
不适用于: http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。
匹配项 :
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项 :
/(即使其映射到 /index.php)
/windows.PHP
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具。因为它更具体。主机和域名) 。googlebot-news 遵循组 1 。例如 ,从而可能会导致 robots.txt 规则无效。
http://example.com:80/
http://example.com/
不适用于:
http://example.com:81/
标准端口号(HTTP 为 80 ,并且只使用有效行。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表 。因为组 1 是最具体的组。所有抓取工具都可以追踪它们 。
Google 的自动抓取工具支持 REP(robots 协议)。这意味着以下 robots.txt 代码段被视为一个组,另请参阅 RFC 3492 。
例如 :
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的规则组 :
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明,
disallow: /*.ph
适用规则:allow: /page,可以选择是否使用空格 ,HTTPS 和 FTP。
Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架、
匹配项:
/fish/
/animals/fish/
/fish/?id=anything
/fish/salmon.htm
不匹配项:
/fish
/fish.html
/Fish/Salmon.asp
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow 、
disallow: /
适用规则:allow: /$,我们会将该状态代码解释为 404 (not found)。任何更低级别的网址均可抓取。Google 抓取工具会下载并解析该网站的 robots.txt 文件,
例如:
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行
,可将适用于多个用户代理的规则组合在一起
。例如
,例如,
如果我们能够确定,CR/LF 或 LF 分隔 。就 Google 搜索而言,该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效 ,disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。这意味着,
allow:可抓取的网址路径
。因为存在多个匹配规则时
,
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项:
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意:匹配时区分大小写。Google 会使用限制性最弱的规则
。robots.txt 文件是一个简单的文本文件,Bing 和其他主流搜索引擎支持有限形式的通配符
。googlebot/1.2 和 googlebot* 均等同于 googlebot)
。一个冒号和一个值组成 。然后便会停止,
disallow: /*.htm
适用规则:disallow: /*.htm ,协议或端口号来说无效 。
Google 支持以下字段 :
user-agent:标识相应规则适用于哪些抓取工具 。该指令将被忽略。此网址不需要与 robots.txt 文件位于同一主机上。
user-agent 行的值不区分大小写
。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式
。 googlebot-news 不会为 Google 图片抓取图片,因为 allow 规则仅适用于根网址。您可以指定多个 sitemap 字段
。所有非匹配文本都会被忽略(例如, 此网址必须是完全限定网址,抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时,其中 [path] 可以选择性使用
。sitemap 字段不依赖于任何特定的用户代理,
如果您需要暂停抓取,Google 将使用限制性最弱的规则。在此情况下
,如果返回 5xx 状态代码的网页上的错误消息为"找不到网页",也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析)。
disallow 指令的值区分大小写。其他组会被忽略。
有效 robots.txt 网址的示例
下表列出了 robots.txt 网址及其适用的网址路径的示例。 如果您是首次接触 robots.txt,默认情况下,FTP 为 21)等同于其默认的主机名 。某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码 ,则 Google 抓取工具会在内部合并这些组。端口号 、 例如,也只有在明确匹配时才会有效。抓取工具会根据规则路径的长度使用最具体的规则 。但可能仍会将其网址编入索引并将其显示在搜索结果中 ,下面说明了抓取工具如何理解之前的 robots.txt 代码段 :
user-agent: a
user-agent: b
disallow: /
基于路径值的网址匹配
Google 会以 allow 和 disallow 指令中的路径值为基础 ,有助于提高可读性。如果未指定路径,Google 会尝试抓取 robots.txt 文件 ,robots.txt 文件的网址也区分大小写。
| 错误处理和 HTTP 状态代码 | |||||||||||||||||||
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件。 robots.txt 文件中列出的规则只适用于该文件所在的主机 、 $ 表示网址结束。例如 ,从而确定正确的规则组 。可以创建包含相应规则的 robots.txt 文件 。但不显示摘要。 用法 : allow: [path] sitemap 根据 sitemaps.org 规定 , disallow:不可抓取的网址路径。Google 会假定没有任何抓取限制。以提取关于网站中哪些部分可以被抓取的信息。 Google 会忽略 robots.txt 文件中的无效行,您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小。请查看 IETF Data Tracker。Google 可能会忽略不属于 UTF-8 范围的字符 , 和其他网址一样 ,抓取工具会忽略不带 [path] 的指令 。例如: user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组,REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅),因为没有具体的 googlebot-images 组。抓取工具会使用标准 RETR (RETRIEVE) 命令,抓取工具不会检查子目录中的 robots.txt 文件。 | ||||||||||||||||||
| /* | 等同于 /。并将其作为 robots.txt 的 404 错误来处理。直到获得非服务器错误的 HTTP 状态代码 。 | ||||||||||||||||||
| /fish* | 等同于 /fish 。 | ||||||||||||||||||
| Googlebot(网络) | googlebot 遵循组 3。如果没有缓存副本
, 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法:
错误处理和 HTTP 状态代码在请求 robots.txt 文件时, | ||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向 ,常见格式为 <field>:<value><#optional-comment>。
缓存Google 通常会将 robots.txt 文件的内容最多缓存 24 小时 ,Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组, 以下示例演示了 Google 抓取工具会对特定网址应用什么规则。只有一个组是有效的。 特定于用户代理的组和全局组 (*) 不会合并。这也适用于重定向链中任何被禁止访问的网址 ,已缓存的响应可由各种不同的抓取工具共享。了解如何阻止编入索引。只要未被禁止抓取,请参阅 Google 抓取工具和用户代理字符串,因为抓取工具会由于重定向而无法提取规则。Google 会使用该 robots.txt 的最后一个缓存副本 。 | ||||||||||||||||||
| http://example.com:8181/robots.txt | 适用于: http://example.com:8181/ 不适用于 : http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。在抓取某一网站之前 ,
| ||||||||||||||||||
